Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

New Creator Theme: Elders! - posted on 1st Sep 2018 at 11:43 AM
Replies: 31 (Who?), Viewed: 3795 times.
Page 1 of 2
Theorist
Original Poster
#1 Old 29th Dec 2017 at 2:40 PM Last edited by varpunen : 29th Dec 2017 at 2:56 PM.
Default Save file with added lots?
I'm really starting to lose my calm with EIG and the "Max memory used" save error. Sometimes it saves and sometimes it crashes in the middle of the saving. But this is not about that, really. I was wondering... since I could export the town and then add all the missing lots with a save file, it would be an easy solution but... Does all those lots affect the size of the said safe file? I really wouldn't want to share a safe file that's already too big to start with. My world is nearly done, so the situation is truly frustrating.

EDIT: One additional question... I noticed that even though the saving in EIG crashes sometimes, some of the added lots seems to be saved into the world and are also visible when back in CAW. Does this mean that these lots are okay and doesn't need to be bulldozed? Can I leave them and continue trying to add lots? At least to me they look fine.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Advertisement
Scholar
#2 Old 29th Dec 2017 at 3:24 PM Last edited by Norn : 29th Dec 2017 at 6:06 PM.
Sorry to hear you are having so much trouble.

I cannot say much about the size of the save file, I haven't experimented with that. I would think that while it surely adds to the size it shouldn't be that much - the objects are in game anyway and only referenced. Also there are things which are better to place in a safe, like lots with ITF elevators, lots with ghosts on them, .... So you can always opt for a mix and match. Place as many lots in EIG and the uncooperative ones in a safe file.

If a lot is saved before crashing it should be fine (the information is written). But in the end, only exporting and playtesting can give you certainty.

Also, volunteering to help testing

[eta] By chance I just had a look at Vendon, a lovely world based on the Riverview map. All lots come with the save, and the .nhd file is about 40 MB large. It isn't a fully developed world though, with 102 lots; 25 residential, 58 commercial and 19 empty (additionally, a lot of the commercial lots are tiny lots for subway stations or decoration).
Theorist
Original Poster
#3 Old 29th Dec 2017 at 10:48 PM
I didn't know about Vendon, so I appreciate that info. I do have most of the lots placed in EIG before it started to misbehave, so the lot amount still to be placed would be around 15, give or take a few. I'm gonna give the EIG a one more change to act right but after that, I think I'm going to go with the save file method.

Yeah, I noticed that EIG doesn't seem to like some ITF items. I placed some crystal flowers on the community garden lot and that resulted a long list of crystal flower error logs into the Sims 3 folder.

When I get the lots placed, I'm going to finally release a test version but since the world is a theme based, it contains CC and not everyone welcomes that.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Top Secret Researcher
#4 Old 30th Dec 2017 at 8:20 AM
I read do NOT use those ITF crystals in other worlds as it can totally mess up your game. I had some in the world I am working on and got rid of them as soon as I read that. I would get rid of them for sure. I have had a save or 2 fail but the lots that saved before the error were fine.
Theorist
Original Poster
#5 Old 30th Dec 2017 at 10:58 AM
Quote:
Originally Posted by daisylee
I read do NOT use those ITF crystals in other worlds as it can totally mess up your game. I had some in the world I am working on and got rid of them as soon as I read that. I would get rid of them for sure. I have had a save or 2 fail but the lots that saved before the error were fine.


Did it say that they were safe to use in normal gameplay, after the world is imported or are they only safe in Oasis Landing?

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Scholar
#6 Old 30th Dec 2017 at 11:03 AM
We used those crystal plants in abundance in our Saturenorn world and didn't have any problems. Which reason was given for not using them outside of Oasis Landing @daisylee?
Theorist
Original Poster
#7 Old 30th Dec 2017 at 3:31 PM
Maybe the problem comes out of which spawner is used. The one spawner spawns the plain, uncharged crystal flower and then there's four spawners for four already charged crystal flowers. It was the four charged ones that gave me the error list.

Anyway, I'm off to test the EIG saving again.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Top Secret Researcher
#8 Old 31st Dec 2017 at 2:39 AM Last edited by daisylee : 6th Jan 2018 at 4:05 AM.
Let me see if I can find where I read that. I was getting the errors when in my world also.

edit: long overdue.... I did some searching and cannot find the posts. Someone here are MTS advised about not using the crystal plants in other worlds, but I cannot find the posts at the moment.
Lab Assistant
#9 Old 5th Jan 2018 at 6:43 PM
As many memory based questions: to big depends on the machine (pc/laptop). Where you get errors another with a faster CPU/GPU or with more RAM memory can have 0 problems... (it's the RAM of your PC which is maxed out)

Adding lots with a saved game can work, Caw is not the same as S3, some of the engines running both might be crossed in usage but the programs itself work in different ways, a max RAM in CAW can be 0 problem in S3.

Not to go to deep in the matter but CAW and Sims3 use the same data to read from but have different write options (all developers of world know that some things have to be done in CAW else they can't be achieved while playing)

Adding Lots to CAW would be preffered (install world and all lots are there), but with adding in a save game the end result will be the same (same data released in 2 different ways but S3 still reads the same data). If the world is "playable" depends on User PC/Laptop. My 15 year old pc won't, the current will do without any problem... Testing with different users will give a better sight on that (saw the first tester volunteering
Theorist
Original Poster
#10 Old 5th Jan 2018 at 10:18 PM Last edited by varpunen : 5th Jan 2018 at 11:42 PM.
I wonder if there's any solution to the "Max memory used" crash. I would so love to place all the lots in CAW/EIG and not use the save file system. This is so frustrating.

Have anyone tried this: http://forums.thesims.com/en_US/dis...ashes-on-sims-3 I've only done that to the base game file but not the rest.

Also, does the size of the Library folder affect the memory usage? If you have a lot of lots in the bin?


Quote:
Originally Posted by Anno2015
As many memory based questions: to big depends on the machine (pc/laptop). Where you get errors another with a faster CPU/GPU or with more RAM memory can have 0 problems...


Well, I have a gaming desktop with 16 GB of RAM and it just got updated again awhile ago. And I have no problems in normal gameplay. It's the EIG that's crashing. And yes, CAW/EIG certainly is a whole other creature, I agree.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Top Secret Researcher
#11 Old 6th Jan 2018 at 4:12 AM
My game is/was setup with Large Address Aware with the base and every EP until EA fixed the limit in one of the EPs and it was no longer needed. Someone with a better memory can clarify about this more. I did this on my laptop but don't think it was needed on my current desktop. I think many/most of us did it at the time to solve the memory issues.

I would also use a clean game when using CAW and add only must have items to it. The less that has to be read the easier for CAW and EIG I am sure. And less to attach to the world file that is not wanted.
Theorist
Original Poster
#12 Old 6th Jan 2018 at 11:47 AM
Quote:
Originally Posted by daisylee
My game is/was setup with Large Address Aware with the base and every EP until EA fixed the limit in one of the EPs and it was no longer needed. Someone with a better memory can clarify about this more. I did this on my laptop but don't think it was needed on my current desktop. I think many/most of us did it at the time to solve the memory issues.

I would also use a clean game when using CAW and add only must have items to it. The less that has to be read the easier for CAW and EIG I am sure. And less to attach to the world file that is not wanted.


I also have a completely new and clean game folder for CAW but do have small amount of cc - 224 MB (completely necessary for a themed world). I too went through the whole LAA thing when it was nedeed and the 4 GB patch. My CAW also has the LAA and the 4 GB patch. WIthout the LAA, my CAW refuses to work at all and only crashes. With LAA, it works fine. The funny thing is that even though EA fixed the limit, my game works way better with being made LAA myself. I noticed this after a reinstall at one point.

I just counted the lots in my world after removing a couple of them and the amount is 118. Is that too much? I mean, doesn't London, New Warsaw and maybe a few others have more than that? I don't think I can remove anymore lots.

I'm just wondering the Cloudwalker's method... Would I dare to raise the memory usage limit for every EP to 8 GB, when now it's 2 GB (except base game).

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
dodgy builder
#13 Old 6th Jan 2018 at 1:03 PM
As long as you have a backup, it should be fine. Interesting though. I can't remember having seen that around before.
Theorist
Original Poster
#14 Old 6th Jan 2018 at 7:16 PM Last edited by varpunen : 7th Jan 2018 at 12:35 AM.
Yeah, I'm a bit hesitant because it's not widely known, I think.

Well, I saved all the lots into a bin, in two seperate parts. Then, I emptied my whole world and started to add lots all over again. After the first "max memory crash" I started to add lots only two to four at a time and this stopped the crashing. I finally got to a point where there is only 8 lots missing due to the fact that EIG refused to safe them even one at a time. I think it might be because almost all are large lots, 5 of them. My world has never been this finished before and it exported nicely, so I'm not going to use a save file after all. I'm going to share those lots in a package format and let anyone who wants to try this world out decide themselves whether or not to use them. I think it would be better this way because save file would make moving with traveler impossible. I'm just so ready to get this world out of my hands.

EDIT: I am now finished and the world is ready. Thank you all for your help and answers.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Top Secret Researcher
#15 Old 7th Jan 2018 at 4:15 AM
YAY! I am glad you found a method that works. Will look forward to checking out your new world.
Theorist
Original Poster
#16 Old 7th Jan 2018 at 1:41 PM
Quote:
Originally Posted by daisylee
YAY! I am glad you found a method that works. Will look forward to checking out your new world.


Thank you. I just hope it runs ok.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Theorist
Original Poster
#17 Old 8th Jan 2018 at 8:03 PM Last edited by varpunen : 9th Jan 2018 at 3:00 PM.
Hi, guys. I was doing a test run with my test sim just to make sure everything was okay and noticed something odd. Everything looks okay in EIG but after exporting and installing the world, some of the patterns get mixed up or are missing. Like I have this one pattern for the counters of this certain nightclub but suddenly another nightclub's floor patterns are replaced with this same pattern. Same goes for the pattern in third club's walls. First I though it was case of a corrupt pattern but after making a fresh user folder and trying again, same happens but this time with another pattern. Third try with a yet again different pattern. The patterns in question are my own, none of the game patterns seems to be affected. Can all these custom patterns have gotten corrupted?

As I placed those same lots in game from the bin on my test run, everything was as it should be. It's the export that screws them up. What's going on?

EDIT: And the memory crash is back.

EDIT2: Using the Cloudwalker method to every EP and SP that allows it, made no difference when it come to the "Max memory used" crash.

EDIT3: Uninstalling patterns had no effect. The textures were just replaced by one of the remaining patterns. I would be able to change th patterns to EA ones but the EIG keeps crashing during every save attempt. I think my world is cursed and I'm about ready to just completely give up. I even tried the Edit Premade World -method but in that case CAW fails to save. Seems hopeless.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Lab Assistant
#18 Old 9th Jan 2018 at 4:51 PM
did you add any objects lately? might be one of them using memory...
Scholar
#19 Old 9th Jan 2018 at 5:04 PM
No, please don't give up! You spend so much time and effort on this (and what I saw from the pictures, this will be an amazing world!) Though I don't have any helpful advice... just what Anno already said. I only had this sort of texture bleeding with a bad cc - after I removed it, everything was ok again. So maybe it's one of the cc objects you use? Maybe try the 50/50 method on the cc folder to see if there is a difference. Also, I can only offer to have a look at the CAW files - maybe I'll notice something, or maybe it's just a matter of configuration.
Theorist
Original Poster
#20 Old 9th Jan 2018 at 7:56 PM
Thank you for the support. I was feeling really low today.

I haven't added anything but one painting resently. I've actually removed items to reduse the cc amount even more. I took out all my own custom patterns to see if they're the cause. I only have one favorite sandstone pattern left - made by PS (don't know who that is) - which I have had for years without any problems. The painting is my own and seems okay by dashboard but I have to test that one out, as well. I'm going to do a test export without my patterns and see if the problem is still there or not.

So a bad cc object can affect the patterns? Patterns themselves doesn't necessarily have to be corrupted then?

Edit: Oh man, I just realised... I did replace TJStreak's deco buildings with Sandy's (ATS3) buildings. I just can't believe that they could be bad...

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Scholar
#21 Old 9th Jan 2018 at 8:23 PM
Well, "bad" doesn't necessarily mean that it's badly done. It may just conflict with something else. The object which caused the texture bleeding was supposed to be a default replacement, but obviously something went wrong during creation process (it was never released because of that issue). So, it could be a pattern or an object. Anything you added to the world, so maybe even the painting. I'm sorry, I don't have much experience with these things so I'm just poking in the dark
Lab Assistant
#22 Old 9th Jan 2018 at 9:03 PM
cc can use patterns, but more likely there is another bug which sucks the memory away... But CC can be the problem

A building (especially a large one) can be the problem; check the source, maybe there others found the same problem (do you know where you donwloaded the buildings from? maybe comments over there name the same problem...) Else you can try removing the last modified CC in the CC folder and try again (make a copy of cc first-> if problem is still there you can easily place it back (doesn't affect problem)
Theorist
Original Poster
#23 Old 9th Jan 2018 at 9:51 PM
Those deco buildings are made by Sandy from Around The Sims 3. She converted them from the Sims 4. But they don't seem to be the problem because I removed everything from the Mods folder, except a few caw items from here, mainly by Graham and a bridge by Bluefunk + Gelina's riverside walls (from her blog). The bleeding still continues.

I wonder if the bleeding gets "locked in" during export and should I do object removal before the export for it to have any effect to the bleeding? Okay, off to test that now.

The New Home of the Mass Effect and Dragon Age Fans: http://bsn.boards.net/ Are you there yet?
My Homepage: Shadow City Sims 3
My Music Videos: PolarDove's Channel
Tuesday is Soylent Green day!
retired moderator
#24 Old 9th Jan 2018 at 10:04 PM
Quote:
Originally Posted by varpunen
Everything looks okay in EIG but after exporting and installing the world, some of the patterns get mixed up or are missing. Like I have this one pattern for the counters of this certain nightclub but suddenly another nightclub's floor patterns are replaced with this same pattern.

Try deleting the following:
Documents\Electronic Arts\The Sims 3\Thumbnails
Documents\Electronic Arts\The Sims 3\WorldCaches

Also you could try removing this file:
Documents\Electronic Arts\The Sims 3\ userPresets.package
Although I'm not sure that would cause this. It can make some pretty cool things happen though, such as making walls show up as floors and vice versa.
Lab Assistant
#25 Old 9th Jan 2018 at 10:24 PM Last edited by Anno2015 : 9th Jan 2018 at 10:34 PM.
hmmm
/me has to think

only other thing I had (but was hard crash most of the times without error) was when I made Lots with objects sticking out of Lots (From rock till parking space) or multiple floors with different c.F.E. edits (lowest basement level pulled down 3th down edited up, 1st basement level down, 1st floor down, 2nd floor up

the last was a memory error (told my PC and not the game = hard crash

and YES before export (CC removal), else you'll possibly export the error (for used objects only) ->
Caw export (or all world imports) is a basic layer for S3, your save game is a layer over it (all edits of the original world are saved (and applied when opening the save game) BUT the first layer (the world) stays the same -> if there is a "corrupted" CC and you remove it the refference to it still "sits" in your world (and the game looks for the CC; when not found replaceses it with non CC model from basegame). So also when you save the game it compares the changes (and the CC reference from the world).

CC which could effect this problem =
additions after last succesfull save
or
CC used for the first time

all other CC wouldn't effect the problem normally
Page 1 of 2
Back to top